Upgrading to Google Drive & Confluence version 2.0.0

The Connector for Google Drive & Confluence version 2.0.0 brings huge improvements in terms of functionality for administrators and end users.

To ensure a smooth upgrade from prior version to version 2.0.0 and onwards, take note of the following items.

Google Drive API Key is Required

Besides the existing authorization details, a Google Drive API key is now required. This must be configured to enable all features. Refer to the updated Administrator Guide.

Google Picker API Must be Enabled

The new file selection dialog in the Drive macro uses Google Picker API. Refer to the updated Administrator Guide for instruction.

My Google Drive Has Been Removed

Due to the improved file selection dialog, personal My Google Drive settings are no longer relevant and has been removed.

The Drive File Macro is Deprecated and Replaced with the Drive Macro

The Drive File macro has been replaced by the new Drive macro.

Some visual improvements have been added to differentiate these macros:

The Drive File macro will continue to work. However, the underlying logic of the macro is actually using the the new Drive macro. All users will need to authenticate to Google Drive to start viewing the Drive files.

We encourage you to start using the new Drive macro and to migrate your existing content to the new Drive macro. There is no automated migration available yet, but please let support@servicerocket.com if you need it.

ServiceRocket plans to remove the old Drive file macro from future versions, planned to be released in December 2016.