What Versions of Salesforce are Compatible with the Connector?

Plugin:Classic Connector for Salesforce & Jira
Question:What Versions of Salesforce are Compatible with the Connector?
Answer:

The Salesforce and JIRA connector requires the Salesforce.com API to be enabled. The Salesforce.com API is enabled by default for Performance, Unlimited, Enterprise, and Developer Editions. Some Professional Edition organizations may also have the API enabled.

Lightning support is not available yet.