Are the Randombits Libraries Still Required?

All modern versions of ServiceRocket add-ons have removed Randombits (RB) libraries dependency.

The Dependency Matrix shows an up-to-date information of which add-on requires which library. There are two sections (for modern and older versions) for comparison.

Despite this improvement, it is not possible for add-on vendors like ServiceRocket to automatically remove libraries that are no longer required inside Confluence. Therefore, manual uninstallation by Confluence administrators is necessary.

Third-party add-ons

Note that there are other third-party add-ons known to use RB libraries. If you use the following add-ons, please check with the add-on vendor if there's available version to support this improvement:

Can I uninstall Randombits libraries now?

If you have upgraded all ServiceRocket add-ons to modern versions, you may remove all RB libraries (including Conveyor Plugin) per ServiceRocket Add-on Dependencies.

If in doubt, you may uninstall all ServiceRocket add-ons followed by all RB libraries. Then, reinstall all ServiceRocket add-ons.