How to solve the issue of add-ons being disabled after updating Core plugins or RB plugins

This page concerns an issue where the RB plugins are updated prematurely, which causes certain add-ons that are dependent on these RB plugins (e.g., Composition Tabs for Confluence, Scaffolding Forms & Templates and Reporting for Confluence) to be disabled.

Our developers are taking steps to solve this issue and hope to have a permanent solution soon.

Meanwhile, steps solving this issue will be outlined below.

Solving the Issue

Method 1

  1. Start by clearing Confluence's plugin cache.
  2. Then, try enabling the affected add-ons again.

Method 2

  1. Install the newest version of all affected add-ons.
  2. If the updated add-ons are still disabled, clear Confluence's plugin cache and then try to enable the add-ons.

Method 3

  1. If the above methods fail, you may try uninstalling all affected add-ons, including their related RB plugins.
  2. Then, reinstall the latest versions of those add-ons, one by one.
  3. If the add-ons are still disabled after reinstallation, clear the plugin cache and try to reenable the add-ons.

Other Suggestions

If you have already tried the above suggestions, then try the following:

  1. Try restarting the server.
  2. Look inside the logs for any installation errors.

Do Not Downgrade RB Plugins!

Here are some additional reminders regarding RB plugins:

  1. Ensure you do not downgrade any RB plugins to a lower version than what is installed by a Confluence add-on.
  2. Doing so may affect other add-ons and may even disable them.