How to Upgrade ServiceRocket add-ons from Confluence 3.x to 4.x and Above?

Take It Step By Step

After you upgrade Confluence, pages that contain ServiceRocket add-ons, specifically Composition, Scaffolding, and Reporting macros may render incorrectly.

If you are upgrading Confluence to v4.3 and above, there might be some problems with the Wiki Markup migration if you upgrade directly from Confluence v3.x to the latest version. It is recommended instead to upgrade Confluence version by version so that your data can be maintained.

Refer to the Confluence safety upgrade steps below to ensure all Wiki Markup data are migrated completely.

Upgrade Instructions for Each Add-on

  1. Before upgrading Confluence, go to Confluence Administration  Add-ons.
  2. Disable the ServiceRocket add-ons.
  3. Upgrade Confluence.
  4. You can upgrade ServiceRocket add-ons via the following methods:
    • Download the .obr files for each ServiceRocket add-ons from the Atlassian Marketplace, upload it via:
      Confluence Administration  Add-ons Upload add-on
    • Confluence Administration  Add-ons  Upgrade
  5. Enable the ServiceRocket add-ons.

Safety Upgrade Paths for Confluence with Composition, Scaffolding, and Reporting

  1. Upgrade Confluence v3.x → Confluence v3.5.x with Composition 2.3.5, Scaffolding 3.4.2, Reporting 3.4.2.
  2. Upgrade Confluence v3.5.x → Confluence 4.2.x with Composition 3.0.3, Scaffolding 4.0.4, Reporting 4.1.0.
  3. Upgrade Confluence v4.2.x → Confluence 4.3.x with Composition 3.0.3, Scaffolding 4.6.5, Reporting 4.1.0.
  4. Upgrade Confluence v4.3.x → Confluence v5.8.x with Composition 4.0.0, Scaffolding 6.3.0, Reporting 5.3.0.
  5. While on Confluence 5.8.x, upgrade according the following upgrade path:
    Composition 4.0.0 & Scaffolding 6.3.0 & Reporting 5.3.0Composition 4.0.0 & Scaffolding 6.3.0 & Reporting 5.8.1Composition 5.0.0 & Scaffolding 8.0.0 & Reporting 6.0.0Composition 5.9.1 & Scaffolding 8.8.0 & Reporting 6.6.0
  6. On Composition ≥5.0.0, Scaffolding ≥8.8.0, Reporting ≥6.6.0, uninstall all older dependencies which are not required by modern version of Composition, Scaffolding, and Reporting. You can refer to this on the ServiceRocket Add-on Dependencies page.
  7. Upgrade Confluence v5.x → Confluence v6.x with the latest compatible version of Composition, Scaffolding, and Reporting.

What if I'm only updating Composition, Scaffolding, or Reporting?

You can check out the following Knowledge Base on each respective ServiceRocket add-ons:

What about other ServiceRocket add-ons?

The rest of the add-ons do not have require a specific upgrade path, as they don't acquire large portion of Wiki Markup content compared to Composition, Scaffolding, and Reporting.

Unmigrated Wiki Markup Content

Confluence might not be able to migrate some Wiki Markup content due to various reason. The most commonly encountered issue is the complicated structure on a page, which causes some part or whole Confluence page to not be migrated. When this happens, you can try the following solutions:

  • rebuild the Confluence Index through Administration → Content Indexing → Rebuild both;
  • running a force migration on Confluence - you can check the specific steps on this Atlassian Documentation;
  • manually migrate the Wiki Markup Content by using the inserting Wiki Markup function on Confluence - you can access it via CTRL + SHIFT + D or Insert Macro → Insert Markup.